Linux WEB

아파치 실행시 libphp5.so 에러

2012.09.13 18:20

호스트웨이 조회 수:17464

아파치 실행시 libphp5.so 에러

 

libphp5.so: cannot restore segment prot after reloc: Permission denied
: 원인은 페도라 계열에서 SELinux와의 퍼미션 충돌이 발생

* 에러메시지
httpd: Syntax error on line 53 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp5.so into server: /usr/local/apache2/modules/libphp5.so:
cannot restore segment prot after reloc: Permission denied

* 해결책
shell> restorecon -R -v /usr/local/apache2/modules


* 안될경우
shell> cd /usr/local/apache2/modules
shell> restorecon -v libphp5.so
shell> chcon -t texrel_shlib_t libphp5.so

 

번호 제목 글쓴이 날짜 조회 수
83 server-status를 이용한 아파치 모니터링 방법 file 호스트웨이 2016.04.05 23395
82 Apache / PHP 최신버전 설치하기 호스트웨이 2015.09.25 24858
81 Indexes 값 제거 호스트웨이 2015.09.18 12916
80 cronlog 설정 호스트웨이 2015.09.18 12996
79 apache - mod_url 설치 호스트웨이 2015.09.18 15460
78 Alternative PHP Cache 설치 & 설정 호스트웨이 2015.09.18 11647
77 웹부하 테스트 - httperf 호스트웨이 2015.09.18 13927
76 Apache Log 관리 방법 (Logrotate) 호스트웨이 2015.09.17 17055
75 Linux LVS 사용하기 호스트웨이 2015.09.16 15462
74 Apache 동시접속자 수 알아내기 호스트웨이 2015.09.13 14110
73 httpd.pid 파일 오류 메시지 (20014) 호스트웨이 2015.09.12 17451
72 외부 링크 도용을 막기 위한 아파치 설정 호스트웨이 2015.09.11 13452
71 WEB에 특정 IP접근 차단 호스트웨이 2015.09.10 15200
70 Apache 설치 후 WEB 403 Forbidden 에러 호스트웨이 2015.09.08 25907
69 Apache-Tomcat Multi Instance 설정 file 호스트웨이 2015.05.28 16196
68 mod_evasive를 이용한 웹 DDoS 방어 호스트웨이 2014.08.19 18445
67 Apache event MPM, Prefork MPM, Worker MPM 방식의 차이점 및 설치 시 설정 방법 호스트웨이 2014.07.19 32492
66 apache 가상호스트(virtualhost) 사용하기 호스트웨이 2013.06.03 30565
65 apache 쓸모없는 로그 남기지 않는 방법. 호스트웨이 2012.12.28 11849
64 64bit 에서 php 컴파일시 에러 메세지 발생 시 대처방법-3 호스트웨이 2012.12.28 13477